Brief tutorial on how to configure a single area OSPF with no authentication.
Overview: 4 routers configured with 4 loopbacks.
Relevant configurations for R1, R2, R3, R4 are posted below.
R1
interface FastEthernet1/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
end
interface Loopback0
ip address 172.16.1.1 255.255.255.0
end
router ospf 1
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.0.0.255 area 0
R2
interface FastEthernet1/0
ip address 10.0.0.2 255.255.255.0
duplex auto
speed auto
end
interface Loopback0
ip address 172.16.2.1 255.255.255.0
end
router ospf 1
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.0.0.255 area 0
R3
interface FastEthernet1/0
ip address 10.0.0.3 255.255.255.0
duplex auto
speed auto
end
interface Loopback0
ip address 172.16.3.1 255.255.255.0
end
router ospf 1
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.0.0.255 area 0
R4
interface FastEthernet1/0
ip address 10.0.0.4 255.255.255.0
duplex auto
speed auto
end
interface Loopback0
ip address 172.16.4.1 255.255.255.0
end
router ospf 1
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.0.0.255 area 0
R1#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.0.0.2 1 FULL/DROTHER 00:00:30 10.0.0.2 FastEthernet1/0
10.0.0.4 1 FULL/BDR 00:00:34 10.0.0.4 FastEthernet1/0
172.16.3.1 1 FULL/DROTHER 00:00:34 10.0.0.3 FastEthernet1/0
R1#sh ip ospf database
OSPF Router with ID (10.0.0.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.0.0.1 10.0.0.1 596 0x80000003 0x00CD35 1
10.0.0.2 10.0.0.2 542 0x80000002 0x00CD33 1
10.0.0.4 10.0.0.4 595 0x80000002 0x00C931 1
172.16.3.1 172.16.3.1 479 0x80000003 0x00781D 1
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.0.0.1 10.0.0.1 482 0x80000003 0x00DF54
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
172.16.1.0 10.0.0.1 440 0x80000001 0x00F6E0 0
172.16.2.0 10.0.0.2 528 0x80000001 0x00E5EF 0
172.16.3.0 172.16.3.1 480 0x80000001 0x00938C 0
172.16.4.0 10.0.0.4 581 0x80000001 0x00C30E 0
R1# sh ip ospf interface
FastEthernet1/0 is up, line protocol is up
Internet Address 10.0.0.1/24, Area 0
Process ID 1, Router ID 10.0.0.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 10.0.0.1, Interface address 10.0.0.1
Backup Designated router (ID) 10.0.0.4, Interface address 10.0.0.4
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 3, Adjacent neighbor count is 3
Adjacent with neighbor 10.0.0.2
Adjacent with neighbor 10.0.0.4 (Backup Designated Router)
Adjacent with neighbor 172.16.3.1
Suppress hello for 0 neighbor(s)
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 4 subnets
O E2 172.16.4.0 [110/20] via 10.0.0.4, 00:11:30, FastEthernet1/0
C 172.16.1.0 is directly connected, Loopback0
O E2 172.16.2.0 [110/20] via 10.0.0.2, 00:10:37, FastEthernet1/0
O E2 172.16.3.0 [110/20] via 10.0.0.3, 00:09:39, FastEthernet1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet1/0
interface FastEthernet1/0
ip address 10.0.0.3 255.255.255.0
duplex auto
speed auto
end
interface Loopback0
ip address 172.16.3.1 255.255.255.0
end
router ospf 1
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.0.0.255 area 0
R4
interface FastEthernet1/0
ip address 10.0.0.4 255.255.255.0
duplex auto
speed auto
end
interface Loopback0
ip address 172.16.4.1 255.255.255.0
end
router ospf 1
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.0.0.255 area 0
R1#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.0.0.2 1 FULL/DROTHER 00:00:30 10.0.0.2 FastEthernet1/0
10.0.0.4 1 FULL/BDR 00:00:34 10.0.0.4 FastEthernet1/0
172.16.3.1 1 FULL/DROTHER 00:00:34 10.0.0.3 FastEthernet1/0
R1#sh ip ospf database
OSPF Router with ID (10.0.0.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.0.0.1 10.0.0.1 596 0x80000003 0x00CD35 1
10.0.0.2 10.0.0.2 542 0x80000002 0x00CD33 1
10.0.0.4 10.0.0.4 595 0x80000002 0x00C931 1
172.16.3.1 172.16.3.1 479 0x80000003 0x00781D 1
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.0.0.1 10.0.0.1 482 0x80000003 0x00DF54
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
172.16.1.0 10.0.0.1 440 0x80000001 0x00F6E0 0
172.16.2.0 10.0.0.2 528 0x80000001 0x00E5EF 0
172.16.3.0 172.16.3.1 480 0x80000001 0x00938C 0
172.16.4.0 10.0.0.4 581 0x80000001 0x00C30E 0
R1# sh ip ospf interface
FastEthernet1/0 is up, line protocol is up
Internet Address 10.0.0.1/24, Area 0
Process ID 1, Router ID 10.0.0.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 10.0.0.1, Interface address 10.0.0.1
Backup Designated router (ID) 10.0.0.4, Interface address 10.0.0.4
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 3, Adjacent neighbor count is 3
Adjacent with neighbor 10.0.0.2
Adjacent with neighbor 10.0.0.4 (Backup Designated Router)
Adjacent with neighbor 172.16.3.1
Suppress hello for 0 neighbor(s)
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 4 subnets
O E2 172.16.4.0 [110/20] via 10.0.0.4, 00:11:30, FastEthernet1/0
C 172.16.1.0 is directly connected, Loopback0
O E2 172.16.2.0 [110/20] via 10.0.0.2, 00:10:37, FastEthernet1/0
O E2 172.16.3.0 [110/20] via 10.0.0.3, 00:09:39, FastEthernet1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet1/0
R1#ping 172.16.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/40 ms
More articles to come so stay tuned!!
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/40 ms
More articles to come so stay tuned!!
No comments:
Post a Comment