Monday, April 2, 2012

Configuring Frame Relay Point to Point and Point to Multipoint

It has been a while since I have written a blog. I have been very busy with life, new job and my CCIE studies. That's right folks, I have started my pursuit of the digits!! I will post my study materials, my schedule, and study plan on another post. In this blogtorial we will configure Frame Relay Point to Point and Point to Multipoint. We will build on this topology and configure EIGRP and explore topics such as split horizon and see how it affects route advertisments. Consider the simple topology below and lets get started.




First, let's get our frame relay switch configured. R1 will be the hub in the Point to multipoint configuration.

Drag and drop a frame relay switch in GNS3 and configure it as below.


Now lets move on to R1 and get it configured.

Router R1

R1#show run
multilink bundle-name authenticated
!
interface Serial1/0
no ip address
encapsulation frame-relay
!--Set the encapsulation. By default uses ietf. 

Though "MFR - Multilink Frame Relay bundle interface" is available.
no fair-queue
serial restart-delay 0
no arp frame-relay
frame-relay type ansi
!--ANSI is the default though you have the options of cisco and q933a.

no frame-relay inverse-arp
!-- No inverse ARP will be used. Makes it too easy :)

!
interface Serial1/0.1 point-to-point
!-- Configure this interface to be point-to-point which is connecting to R2

ip address 10.1.1.1 255.255.255.0
snmp trap link-status
no arp frame-relay
frame-relay interface-dlci 102
!
interface Serial1/0.2 multipoint
!--Configure this interface to be multipoint which will be 

connecting to R3 and R4
ip address 172.16.1.1 255.255.255.0
snmp trap link-status
no arp frame-relay
frame-relay map ip 172.16.1.2 103 broadcast
frame-relay map ip 172.16.1.3 104 broadcast
!--Frame relay ip mappings so routers can 

find each other since we have turned off Inverse Arp
!
end

Router R2

R2#show run
ip cef
multilink bundle-name authenticated
!
interface Serial1/0
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay

serial restart-delay 0
no arp frame-relay
frame-relay map ip 10.1.1.1 201 broadcast
frame-relay interface-dlci 201
no frame-relay inverse-arp

!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
end

Router R3

R3#show run
ip cef
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial1/0
ip address 172.16.1.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
no arp frame-relay
frame-relay map ip 172.16.1.3 301 broadcast
frame-relay map ip 172.16.1.1 301 broadcast
frame-relay interface-dlci 301
no frame-relay inverse-arp

!
end

Router R4

R4#show run
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Serial1/0
ip address 172.16.1.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
no arp frame-relay
frame-relay map ip 172.16.1.2 401 broadcast
frame-relay map ip 172.16.1.1 401 broadcast
frame-relay interface-dlci 401
no frame-relay inverse-arp
!

end

Let's verify with a few show commands.


Note that there are 3 PVC status.

  • Active which means both local and remote end are configured properly.
  • Inactive which usually means remote end is NOT configured properly.
  • Deleted which usually means local end is NOT configured properly.

LMI defaults to ANSI, Req Sent and Msgs rcvd should be incrementing which also verifies normal operation. 

Many more articles to come, please comment or +1 and/or join this site on the right ---->

No comments:

Post a Comment