Tuesday, March 26, 2013

BGP - Troubleshooting Lab 2

Objective
  • R3 and R4 must have 5.5.5.5/32 and 6.6.6.6/32 in their BGP/routing table. 
Sounds simple..? Well how about you figure it out then :) .. Here is the topology. 
Restrictions
  • Static routes should not be added anywhere!! In other words, get BGP to work properly. 
You should be able to figure out the issues with the following show commands below.  

 R1#show ip bgp nei 1.1.1.2 advertised-routes  
 BGP table version is 3, local router ID is 6.6.6.6  
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,  
        r RIB-failure, S Stale  
 Origin codes: i - IGP, e - EGP, ? - incomplete  
   Network     Next Hop      Metric LocPrf Weight Path  
 *> 5.5.5.5/32    0.0.0.0         0          32768 i  
 *> 6.6.6.6/32    0.0.0.0         0          32768 i  

 R2#show ip bgp  
 BGP table version is 3, local router ID is 3.3.3.2  
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,  
        r RIB-failure, S Stale  
 Origin codes: i - IGP, e - EGP, ? - incomplete  
   Network     Next Hop      Metric LocPrf Weight Path  
 *> 5.5.5.5/32    1.1.1.1         0            0   1 i  
 *> 6.6.6.6/32    1.1.1.1         0            0   1 i  

 R2#show ip route  
    1.0.0.0/24 is subnetted, 1 subnets  
 C    1.1.1.0 is directly connected, FastEthernet1/0  
    2.0.0.0/24 is subnetted, 1 subnets  
 C    2.2.2.0 is directly connected, FastEthernet2/0  
    3.0.0.0/24 is subnetted, 1 subnets  
 C    3.3.3.0 is directly connected, FastEthernet1/1  
    5.0.0.0/32 is subnetted, 1 subnets  
 B    5.5.5.5 [20/0] via 1.1.1.1, 00:10:49  
    6.0.0.0/32 is subnetted, 1 subnets  
 B    6.6.6.6 [20/0] via 1.1.1.1, 00:10:49  

 R2#show run | sec bgp  
 router bgp 2  
  no synchronization  
  bgp log-neighbor-changes  
  neighbor 1.1.1.1 remote-as 1  
  neighbor 1.1.1.1 soft-reconfiguration inbound  
  neighbor 2.2.2.3 remote-as 2  
  neighbor 2.2.2.3 next-hop-self  
  neighbor 2.2.2.3 prefix-list adv-r3-out out  
  neighbor 3.3.3.4 remote-as 4  
  neighbor 3.3.3.4 prefix-list adv-r4-out out  
  no auto-summary  

 R2#show ip prefix-list  
 ip prefix-list adv-r3-out: 2 entries  
   seq 10 permit 5.5.5.5/32  
   seq 20 permit 6.6.6.6/32  
 ip prefix-list adv-r4-out: 2 entries  
   seq 10 permit 5.5.5.5/32  
   seq 20 permit 6.6.6.6/32  

 R2#show ip bgp 5.5.5.5  
 BGP routing table entry for 5.5.5.5/32, version 2  
 Paths: (1 available, best #1, table Default-IP-Routing-Table, not advertised to any peer)  
  Not advertised to any peer  
  1, (received & used)  
   1.1.1.1 from 1.1.1.1 (6.6.6.6)  
    Origin IGP, metric 0, localpref 100, valid, external, best  
    Community: no-advertise  
 R2#show ip bgp 6.6.6.6  
 BGP routing table entry for 6.6.6.6/32, version 3  
 Paths: (1 available, best #1, table Default-IP-Routing-Table, not advertised to EBGP peer)  
  Advertised to update-groups:  
     2  
  1, (received & used)  
   1.1.1.1 from 1.1.1.1 (6.6.6.6)  
    Origin IGP, metric 0, localpref 100, valid, external, best  
    Community: no-export  

 R3#show ip bgp  
 BGP table version is 2, local router ID is 2.2.2.3  
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,  
        r RIB-failure, S Stale  
 Origin codes: i - IGP, e - EGP, ? - incomplete  
   Network     Next Hop      Metric LocPrf Weight Path  
 *>i6.6.6.6/32    2.2.2.2         0  100      0    1 i  

 R3#show run | sec bgp  
 router bgp 2  
  no synchronization  
  bgp log-neighbor-changes  
  neighbor 2.2.2.2 remote-as 2  
  no auto-summary  

 R3#show ip route 
    2.0.0.0/24 is subnetted, 1 subnets  
 C    2.2.2.0 is directly connected, FastEthernet1/0  
    6.0.0.0/32 is subnetted, 1 subnets  
 B    6.6.6.6 [200/0] via 2.2.2.2, 01:59:56  

 R4#show run | sec bgp  
 router bgp 4  
  no synchronization  
  bgp log-neighbor-changes  
  neighbor 3.3.3.2 remote-as 2 
  neighbor 3.3.3.2 distribute-list block-most-routes-allow-certain in 
  no auto-summary  

 R4#show ip bgp summary  
 BGP router identifier 3.3.3.4, local AS number 4  
 BGP table version is 1, main routing table version 1  
 Neighbor    V     AS MsgRcvd MsgSent  TblVer InQ OutQ Up/Down State/PfxRcd  
 3.3.3.2     4     2   124   124    1  0  0             02:03:05     0  

 ip access-list standard block-most-routes-allow-certain
  permit 5.5.5.5
  permit 6.6.6.6
  deny   5.5.5.0 0.0.0.255
  deny   6.6.6.0 0.0.0.255


R4#show ip route  
    3.0.0.0/24 is subnetted, 1 subnets  
 C    3.3.3.0 is directly connected, FastEthernet1/0  
  • Why is 5.5.5.5/32 NOT in R3's BGP/routing table? 
  • Why is 5.5.5.5/32 and 6.6.6.6/32 NOT in R4's BGP/routing table?
  • What would you do to get this resolved??

Please leave comments...

6 comments:

  1. Can you post the gns3 file please?

    ReplyDelete
    Replies
    1. https://drive.google.com/folderview?id=0B9lBjpYBzuFoamxtUXlRYmxvN2M&usp=sharing

      Delete
  2. Hi Arwin,
    For me this configuration worked.

    R3#sh run | sec bgp
    router bgp 2
    synchronization

    This gave me the output of both the routes in my BGP.
    R3#sh ip bg
    R3#sh ip bgp
    BGP table version is 5, local router ID is 2.2.2.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path
    *>i5.5.5.5/32 2.2.2.2 0 100 0 1 i
    *>i6.6.6.6/32 2.2.2.2 0 100 0 1 i

    Also before working on the Troubleshooting part, when i did the configuration on GNS3 based on your template, both these Routes were showing in my BGP table but not in the Routing table.
    Once i gave the Sync command as i saw it was an IBGP router for R2, I was able to see both the routes in the routing table.

    R3#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    2.0.0.0/24 is subnetted, 1 subnets
    C 2.2.2.0 is directly connected, FastEthernet0/0
    5.0.0.0/32 is subnetted, 1 subnets
    B 5.5.5.5 [200/0] via 2.2.2.2, 00:05:20
    6.0.0.0/32 is subnetted, 1 subnets
    B 6.6.6.6 [200/0] via 2.2.2.2, 00:05:20

    ReplyDelete
    Replies
    1. My email is arwinr@gmail.com...send me an email and i can tell you how to figure out the issue with just the show commands posted above.

      Thank you

      Delete
  3. R1(config-router)#no neighbor 1.1.1.2 send-community, will solve this.
    OR
    (on R1 again)
    access-list 5 permit 5.5.5.5 0.0.0.0
    #example of ACL5
    access-list 6 permit 6.6.6.6 0.0.0.0
    #example of ACL6
    neighbor 1.1.1.2 route-map mapName out
    #example of neighbor command
    route-map mapName
    #example of route map
    match ip address 5
    NO set community no-export #changes
    match ip address 6
    NO set community no-advertise #changes


    ReplyDelete