Thursday, September 11, 2014

BGP - Troubleshooting Lab 3

Objective: 
  • Establish iBGP between R1 and R2. 
Restrictions: 
  • Cannot change AS numbers on any of the routers.
  • No other static routes can be added 
  • No interface changes
  • No tunnels
Topology below:
I came across this issue the other day and it took me a few minutes to figure it out. So let's see how y'all do. 

Post your comments below on how you would solve this issue. 

Configuration and other information.

R1 Interface and BGP config.

 R1#
 !  
 interface Loopback0  
  ip address 10.10.10.1 255.255.255.255  
 !  
 interface FastEthernet0/0  
  description connected to router 2  
  ip address 1.1.1.1 255.255.255.0  
  duplex auto  
  speed auto  
 !  
 router ospf 1
  network 1.1.1.0 0.0.0.255 area 0 
 !  
 router bgp 1  
  no synchronization  
  bgp log-neighbor-changes  
  neighbor 10.10.10.2 remote-as 2  
  neighbor 10.10.10.2 local-as 2 no-prepend replace-as  
  neighbor 10.10.10.2 update-source Loopback0  
  no auto-summary  

R2 Interface and BGP config

 R2#  
 !  
 interface Loopback0  
  ip address 10.10.10.2 255.255.255.255  
 !  
 interface FastEthernet0/0  
  description connected to router 1  
  ip address 1.1.1.2 255.255.255.0  
  duplex auto  
  speed auto  
 !  
 router ospf 1
  network 1.1.1.0 0.0.0.255 area 0
 !  
 router bgp 2  
  no synchronization  
  bgp log-neighbor-changes  
  neighbor 10.10.10.1 remote-as 2  
  neighbor 10.10.10.1 update-source Loopback0  
  no auto-summary  

Pings are successful between R1 and R2.

 R1#ping 10.10.10.2  
 Type escape sequence to abort.  
 Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:  
 !!!!!  
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms  
 R1#ping 1.1.1.2  
 Type escape sequence to abort.  
 Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:  
 !!!!!  
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms  

BGP is not coming up between R1 and R2.

 R1#show ip bgp summ  
 BGP router identifier 1.1.1.1, local AS number 1  
 BGP table version is 1, main routing table version 1  
 Neighbor    V  AS MsgRcvd MsgSent  TblVer InQ OutQ Up/Down State/PfxRcd  
 10.10.10.2   4   2    0    0    0  0  0 never  Idle  
 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!  
 R2#show ip bgp summ  
 BGP router identifier 1.1.1.2, local AS number 2  
 BGP table version is 1, main routing table version 1  
 Neighbor    V  AS MsgRcvd MsgSent  TblVer InQ OutQ Up/Down State/PfxRcd  
 10.10.10.1   4   2    0    0    0  0  0 never  Active  

Many more articles to come so ....

Please subscribe/comment/+1 if you like my posts as it keeps me motivated to write more and spread the knowledge.

Post comments below.

2 comments:

  1. This is an interesting issue, as I never had the need to use de "local-as" feature; but if you do a "show ip bgp neighbors" on R1 it gives the indications that "EBGP peer not directly connected". With ebgp-multihop I was able to resolve the issue.
    Also, in my lab I had to add the loopback interfaces to the IGP.

    Was this your solution?

    ReplyDelete
    Replies
    1. ebgp multihop does solves the issue. Even though this is an iBGP peering, ebgp-multihop was still needed because iBGP was mimic-ed using the local-as feature.

      Good job!!

      Delete