Tuesday, March 24, 2015

Configuring OSPF - Summarization Lab

As the CCIE Lab exam requires you to the think outside the box a bit, I will do the same on this lab. Here is a simple topology and the basic start up configuration.

Objectives:

  • Summarize 192.168.1.2/32 from Area 2 as 192.168.1.0/24 into area 0.

Restrictions:

  • Do not use area-range command or summary-address to summarize the routes into Area 0.
  • R3 and other routers in Area 0 or any new additional areas should only have the summary address to reach 192.168.1.2. 
  • If prefix 192.168.1.2/32 is withdrawn (i.e shutdown loopback0 on R2) from R1 OSPF database then 192.168.1.0/24 should not be summarized/advertised into area 0.

Startup Configuration:

 R1#  
 interface GigabitEthernet1.12  
  encapsulation dot1Q 12  
  ip address 12.12.12.1 255.255.255.0  
 !  
 interface GigabitEthernet1.13  
  encapsulation dot1Q 13  
  ip address 13.13.13.1 255.255.255.0  
 !  
 router ospf 1  
  network 12.12.12.0 0.0.0.255 area 2  
  network 13.13.13.0 0.0.0.255 area 0  

 R2#  
 interface GigabitEthernet1.12  
  encapsulation dot1Q 12  
  ip address 12.12.12.2 255.255.255.0  
 !
 interface loopback2
  ip address 192.168.1.2 255.255.255.255
 !
 router ospf 1  
  network 12.12.12.0 0.0.0.255 area 2  
  network 192.168.1.2 0.0.0.0 area 2

 R3#  
 !
 interface GigabitEthernet1.13  
  encapsulation dot1Q 13  
  ip address 13.13.13.3 255.255.255.0  
 !  
 router ospf 1  
  network 13.13.13.0 0.0.0.255 area 0  

Post your answers below.

Many more articles to come so ....

Please subscribe/comment/+1 if you like my posts as it keeps me motivated to write more and spread the knowledge.

"Only those who dare to go too far ... can know how far they can really go..."