Here is the topology so let's get going.
Relevant configurations are posted below.
On R1 let's get interfaces, NAT and BGP configured to work with R6.
R1#sh run int gig3/0
interface GigabitEthernet3/0
description Connected to R6
ip address 13.13.13.1 255.255.255.0
ip nat outside
negotiation auto
end
R1#show run | sec route-map
route-map eBGPNAT-ISPB permit 10
match ip address 1
match interface GigabitEthernet3/0
R1#sh run | incl ip nat
ip nat inside source route-map eBGPNAT-ISPB interface GigabitEthernet3/0 overload
R1#sh run | sec bgp
router bgp 22222
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
network 11.11.11.0 mask 255.255.255.0
network 22.22.22.0 mask 255.255.255.0
neighbor 11.11.11.4 remote-as 11111
neighbor 11.11.11.4 route-map SETEBGPLOCALPREF in
neighbor 13.13.13.6 remote-as 33333
neighbor 13.13.13.6 route-map SETEBGPLOCALPREF in
neighbor 22.22.22.2 remote-as 22222
neighbor 22.22.22.2 next-hop-self
neighbor 22.22.22.2 route-map SETIBGPDEFLOCALPREF in
no auto-summary
Now let's get R2 configured.
R2#sh run int gig3/0
R2#sh run int gig3/0
interface GigabitEthernet3/0
description Connected to R7
ip address 14.14.14.2 255.255.255.0
ip nat outside
ip virtual-reassembly
negotiation auto
end
R2#show run | sec route-map
description Connected to R7
ip address 14.14.14.2 255.255.255.0
ip nat outside
ip virtual-reassembly
negotiation auto
end
R2#show run | sec route-map
route-map eBGPNAT-ISPB permit 10
match ip address 1
match interface GigabitEthernet3/0
R2#sh run | incl ip nat
ip nat inside source route-map eBGPNAT-ISPB interface GigabitEthernet3/0 overload
R2#sh run | sec bgp
router bgp 22222
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
network 12.12.12.0 mask 255.255.255.0
network 22.22.22.0 mask 255.255.255.0
neighbor 12.12.12.5 remote-as 11111
neighbor 12.12.12.5 route-map SETEBGPLOCALPREF in
neighbor 14.14.14.7 remote-as 33333
neighbor 14.14.14.7 route-map SETEBGPLOCALPREF in
neighbor 22.22.22.1 remote-as 22222
neighbor 22.22.22.1 next-hop-self
neighbor 22.22.22.1 route-map SETIBGPDEFLOCALPREF in
no auto-summary
R6 and R7 are setup exactly as R4 and R5 from the previous blogtorial "Configuring BGP - Dual Homed Design" with the exception of the ASN and ip addresses.
Few show commands to verify connectivity, default routes and local preference.
1st Failover scenario: R1 looses connectivity to ISP-A.
Soon as I shut the interface for ISP-A, the default route from ISP-B takes over and now I am using ISP-B for R1's internet. R2 at this time is still using ISP-A since R2's connection to ISP-A works.
Full router configurations for all 7 routers.
Many more articles to come so stay tuned!! Please subscribe to my posts by clicking "Join this Site" on the right.
Brother, I tried to check the config for the router using the link , however the link is dead , cant view it
ReplyDeleteCould you reupload it please.
I will look for them but I am not sure if I actually have them.
Delete