Friday, January 9, 2015

EIGRP - Troubleshooting LAB 1

Objective:
  • When Gig2 is shutdown on R1, metric for the route to reach Loopback1 should not change on R2.  
Here is a simple topology and let's get started.


Relevant configs are posted below so you can lab it up. 

R1
 hostname R1   
 interface Loopback1                                                           
  ip address 10.0.0.1 255.255.255.0                                                   
 !                                                                    
 interface GigabitEthernet1        
  description connected to r2                                               
  ip address 1.1.1.1 255.255.255.0 
  ip summary-address eigrp 100 10.0.0.0 255.255.254.0
 !                                                                    
 interface GigabitEthernet2                                                       
  ip address 10.0.1.1 255.255.255.0
 !                                                                    
 !                                                                    
 router eigrp 100                                                            
  network 1.1.1.0 0.0.0.255                                                       
  redistribute connected                                                         
 !                    

R2
 hostname R2  
 interface GigabitEthernet1  
  ip address 1.1.1.2 255.255.255.0  
 !  
 router eigrp 100  
  network 1.1.1.0 0.0.0.255  

Take note of the metric (3072) for the route in R2 to reach R1's Loopback1 and Gig2.

 R2#sh ip route   
 
 Gateway of last resort is not set  
    1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks  
 C    1.1.1.0/24 is directly connected, GigabitEthernet1  
 L    1.1.1.2/32 is directly connected, GigabitEthernet1  
    10.0.0.0/23 is subnetted, 1 subnets  
 D    10.0.0.0 [90/3072] via 1.1.1.1, 00:03:59, GigabitEthernet1  
 

Now shutdown Gig2 on R1 and notice the metric (130816) for the route in R2 to reach 10.0.0.0/23 has changed.
 R1#conf t                                                                
 Enter configuration commands, one per line. End with CNTL/Z.                        
 R1(config)#int gig2                                                           
 R1(config-if)#                                                             
 R1(config-if)#shutdown  
 !!!!!  
 !!!!!  
 R2#sh ip route   
 Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
     E1 - OSPF external type 1, E2 - OSPF external type 2  
     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
     ia - IS-IS inter area, * - candidate default, U - per-user static route  
     o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
     a - application route  
     + - replicated route, % - next hop override  
 Gateway of last resort is not set  
    1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks  
 C    1.1.1.0/24 is directly connected, GigabitEthernet1  
 L    1.1.1.2/32 is directly connected, GigabitEthernet1  
    10.0.0.0/23 is subnetted, 1 subnets  
 D    10.0.0.0 [90/130816] via 1.1.1.1, 00:00:05, GigabitEthernet1  

Post comments on possible solutions as to how you can avoid the metric change on R2 when R1's Loopback1 is shutdown.

Many more articles to come so ....

Please subscribe/comment/+1 if you like my posts as it keeps me motivated to write more and spread the knowledge.

"Unless you attempt to do something beyond that, which you've already mastered, you will never grow."
   

No comments:

Post a Comment