Monday, February 2, 2015

Troubleshooting OSPF - LAB 1

Here is a quick lab I put together to really test your knowledge about OSPF Path selection and some of the hidden rules behind the path selection.

Simple topology below.


Objective: 
  • R3 should choose R2 over Gi1.23 to reach R1 loopback 150.1.1.1/32. Imagine that this is a 40Gbit link where as Gi1.13 is just a 100Mb link. Currently R3 is choosing Gi1.13 to reach R1 loopback 150.1.1.1/32. 
Restrictions:
  • Do not configure any new routing protocols.
  • Do not change Area numbers.
  • Do not create any NEW areas. 
  • Do not change OSPF cost values
  • R3 should choose R1 with OSPF as the routing protocol so no STATIC routes etc. 
Configuration excerpts below so you can configure it in your lab.
 R1#  
 !  
 interface Loopback0  
  ip address 150.1.1.1 255.255.255.255  
 !  
 interface GigabitEthernet1.12  
  encapsulation dot1Q 12  
  ip address 12.12.12.1 255.255.255.0  
  ip ospf hello-interval 1  
  ip ospf 1 area 0  
 !  
 interface GigabitEthernet1.13  
  encapsulation dot1Q 13  
  ip address 13.13.13.1 255.255.255.0  
  ip ospf hello-interval 1  
  ip ospf 1 area 1  
 !  
 router ospf 1  
  network 150.1.1.1 0.0.0.0 area 0  

 R2#  
 !  
 interface Loopback0  
  ip address 150.1.2.2 255.255.255.255  
 !  
 interface GigabitEthernet1.12  
  encapsulation dot1Q 12  
  ip address 12.12.12.2 255.255.255.0  
  ip ospf hello-interval 1  
  ip ospf 1 area 0  
 !  
 interface GigabitEthernet1.23  
  encapsulation dot1Q 23  
  ip address 23.23.23.2 255.255.255.0  
  ip ospf hello-interval 1  
  ip ospf 1 area 1  
 !  
 router ospf 1  
  area 1 virtual-link 150.1.3.3  

 R3#  
 !  
 interface Loopback0  
  ip address 150.1.3.3 255.255.255.255  
 !  
 interface GigabitEthernet1.13  
  encapsulation dot1Q 13  
  ip address 13.13.13.3 255.255.255.0  
  ip ospf hello-interval 1  
  ip ospf 1 area 1  
 !  
 interface GigabitEthernet1.23  
  encapsulation dot1Q 23  
  ip address 23.23.23.3 255.255.255.0  
  ip ospf hello-interval 1  
  ip ospf 1 area 1  
 !  
 interface GigabitEthernet1.34  
  encapsulation dot1Q 34  
  ip address 34.34.34.3 255.255.255.0  
  ip ospf hello-interval 1  
  ip ospf 1 area 2  
 !  
 router ospf 1  
  area 1 virtual-link 150.1.2.2  

 R4#  
 !  
 interface Loopback0  
  ip address 150.1.4.4 255.255.255.255  
 !  
 interface GigabitEthernet1.34  
  encapsulation dot1Q 34  
  ip address 34.34.34.4 255.255.255.0  
  ip ospf hello-interval 1  
  ip ospf 1 area 2  
 !  
 router ospf 1  

 R3#show ip route 150.1.1.1  
 Routing entry for 150.1.1.1/32  
  Known via "ospf 1", distance 110, metric 2, type intra area  
  Last update from 13.13.13.1 on GigabitEthernet1.13, 00:04:55 ago  
  Routing Descriptor Blocks:  
  * 13.13.13.1, from 150.1.1.1, 00:04:55 ago, via GigabitEthernet1.13  
    Route metric is 2, traffic share count is 1  

 R3# sh ip os nei   
 Neighbor ID   Pri  State      Dead Time  Address     Interface  
 150.1.2.2     0  FULL/ -      -    23.23.23.2   OSPF_VL1  
 150.1.1.1     1  FULL/DR     00:00:03  13.13.13.1   GigabitEthernet1.13  
 150.1.2.2     1  FULL/DR     00:00:03  23.23.23.2   GigabitEthernet1.23  
 150.1.4.4     1  FULL/DR     00:00:03  34.34.34.4   GigabitEthernet1.34  

 R3#sh ip os int brief   
 Interface  PID  Area      IP Address/Mask  Cost State Nbrs F/C  
 VL1     1   0        23.23.23.3/24   1   P2P  1/1  
 Gi1.13    1   1        13.13.13.3/24   1   BDR  1/1  
 Gi1.23    1   1        23.23.23.3/24   1   BDR  1/1  
 Gi1.34    1   2        34.34.34.3/24   1   BDR  1/1  

Post comments on how you can get R3 to choose (Gi1.23) R2 -> R1 to reach R1's loopback 150.1.1.1/32.

Many more articles to come so ....

Please subscribe/comment/+1 if you like my posts as it keeps me motivated to write more and spread the knowledge.

"When you're resting to renew your reserves, it's much different than resting to avoid your day. When you're psyched up and excited for your life, when you're excited for what you've planned to accomplish for the day, it's amazing. You'll wake up before the alarm clock even tries to startle you awake. Your successes fuel your ambition. Your successes give you extra energy. Your successes pave the way for more successes"

No comments:

Post a Comment