Monday, May 21, 2018

Configuring OTV - Unicast Transport Mode - OTV Adjacency Server

In this blogtorial, we will be configuring OTV using unicast-only transport mode as opposed to using multicast to discover neighbors etc. In order to use unicast-only transport, we have to enable and configure OTV Adjacency Server feature. Please see previous blogtorial (Configuring OTV - OTV Configuration and Verification) if you want more information on configuring OTV using multicast.

This topology is the same as my previous blogtorial.


What is an OTV Adjacency Server?


"Overlay Transport Virtualization (OTV) provides support for nonmulticast-capable, unicast-only core networks through the OTV Adjacency Server feature. An edge device is configured as an adjacency server (primary or secondary). All other edge devices are configured with the IPv4 addresses of the primary and secondary adjacency servers, after which the edge devices communicate their reachability and capability information to the primary and secondary adjacency servers. Wide-Area Networking Configuration Guide: Overlay Transport Virtualization, Cisco IOS XE Release 3S 2 OTV Adjacency Server Restrictions for OTV Adjacency Server You can configure more than one adjacency server per VPN. An adjacency server can serve multiple VPNs. An adjacency server can also connect an OTV site to one or more VPNs." - Cisco.com

First let's get the IP and the transport layer or the underlay network configured.

We will start with the East site.

CORE-East-1


I had to bring up two interfaces between the virtual core and edge because I couldn't configure just one port as trunk. In real devices this should not be necessary.

 hostname CORE-East-1  
 !  
 ip cef  
 !  
 spanning-tree mode rapid-pvst  
 spanning-tree extend system-id  
 spanning-tree vlan 5 priority 4096  
 !  
 interface Ethernet0/0  
  description ESXI-VMS  
  switchport access vlan 5  
  switchport mode access  
 !  
 interface Ethernet0/2  
  description interface_to_extend_the_vlan  
  switchport mode access  
  switchport access vlan 5  
 !  
 interface Ethernet0/3  
  description interface_to_bring_up_OTV_site_vlan  
  switchport access vlan 56  
  switchport mode access  
 !  
 interface Vlan5  
  description ESXI-VMS  
  ip address 5.5.5.1 255.255.255.0  
 !  

OTV-East-Edge-1 

For now we will configure just the IP interfaces and enable OSPF so we have Layer 3 IP reachability between the sites.

 license grace-period  
 !  
 hostname OTV-East-Edge-1  
 !  
 !!--Enable the required features
 feature ospf  
 feature otv 
 !  
 !!--Create the necessary VLANs
 vlan 5  
  name ESXI-VMS  
 vlan 56  
  name OTV_SITE_VLAN  
 !  
 interface Ethernet2/1  
  ip address 3.3.3.1/30  
  no shutdown  
 !  
 interface Ethernet2/2  
  switchport  
  switchport access vlan 5  
  no shutdown  
 !  
 interface Ethernet2/3  
  switchport  
  switchport access vlan 56  
  no shutdown  
 !  
 !!--Enabling OSPF so we have unicast reachability
 router ospf 1  
  network 0.0.0.0/0 area 0.0.0.0  

ISN-East-1 

Now let's get the Data Center Edge configured. It's considered best practices to bring the DCI (Data Center Interconnects) into its own set of routers, therefore in this topology I am bringing them into a pair of ISN routers (InterSite Network Routers), but technically they could have gone directly into the Core Routers (perhaps in its own VDC).

 hostname ISN-East-1  
 !  
 ip cef  
 !  
 interface Ethernet0/0  
  description DCI - Data Center Interconnect  
  no switchport  
  ip address 2.2.2.2 255.255.255.252  
 !  
 interface Ethernet0/1  
  description Connected_TO_OTV_EDGE  
  no switchport  
  ip address 3.3.3.2 255.255.255.252  
 !  
 router ospf 1  
  network 0.0.0.0 255.255.255.255 area 0  
 !  

Now let's get the West Site configured the same as the East Site and then we will move on to the configurations pertaining to the overlay network and configure OTV.

Core-West-1  

  hostname CORE-West-1   
  !   
  ip cef   
  !   
  spanning-tree mode rapid-pvst   
  spanning-tree extend system-id   
  spanning-tree vlan 5 priority 4096   
  !   
  interface Ethernet0/0   
  description ESXI-VMS   
  switchport access vlan 5   
  switchport mode access   
  !   
  interface Ethernet0/2   
  description interface_to_extend_the_vlan   
  switchport mode access   
  switchport access vlan 5   
  !   
  interface Ethernet0/3   
  description interface_to_bring_up_OTV_site_vlan   
  switchport access vlan 55  
  switchport mode access   
  !   
  interface Vlan5   
  description ESXI-VMS   
  ip address 5.5.5.1 255.255.255.0   
  !   

OTV-West-Edge-1
  license grace-period   
  !   
  hostname OTV-West-Edge-1   
  !   
  !!--Enable the required features  
  feature ospf   
  feature otv 
  !   
  !!--Create the necessary VLANs  
  vlan 5   
  name ESXI-VMS   
  vlan 55   
  name OTV_SITE_VLAN   
  !   
  interface Ethernet2/1   
  ip address 1.1.1.1/30   
  no shutdown   
  !   
  interface Ethernet2/2   
  switchport   
  switchport access vlan 5   
  no shutdown   
  !   
  interface Ethernet2/3   
  switchport   
  switchport access vlan 56   
  no shutdown   
  !   
  !!--Enabling OSPF so we have unicast reachability  
  router ospf 1   
  network 0.0.0.0/0 area 0.0.0.0   

ISN-West-1
 hostname ISN-West-1   
  !    
  !   
  ip cef   
  !   
  interface Ethernet0/0   
  description DCI - Data Center Interconnect   
  no switchport   
  ip address 2.2.2.1 255.255.255.252   
  !   
  interface Ethernet0/1   
  description Connected_TO_OTV_EDGE   
  no switchport   
  ip address 1.1.1.2 255.255.255.252   
  !   
  router ospf 1   
  network 0.0.0.0 255.255.255.255 area 0   

At this point, we should have full IP unicast reachability between the devices and multicast has not been enabled. Let's now configure OTV with OTV Adjacency server. In our topology OTV-East-Edge-1 will be the OTV Adjacency Server and OTV-West-Edge-1 will be the OTV client.

OTV-East-Edge-1 will use the join interface, which in this case Ethernet 2/1's IP as the adjacency server IP that the remote clients should be configured with.

OTV-East-Edge-1 OTV Configurations

 hostname OTV-East-Edge-1  
 !  
 vlan 56  
  name OTV_SITE_VLAN  
 otv site-vlan 56
 !  
 interface Overlay1  
  otv join-interface Ethernet2/1  
  otv adjacency-server unicast-only !!--OTV Adjacency Server
  otv extend-vlan 5  
  no shutdown  

OTV-West-Edge-1 OTV Configurations

 hostname OTV-West-Edge-1  
 !  
 vlan 55  
  name OTV_SITE_VLAN  
 otv site-vlan 55  
 !  
 interface Overlay1  
  otv join-interface Ethernet2/1  
  otv use-adjacency-server 3.3.3.1 unicast-only !!--OTV Adjacency Client 
  otv extend-vlan 5  
  no shutdown  

Verification
OTV-East-Edge-1# show otv 
 OTV Overlay Information  
 Overlay interface Overlay1  
  VPN name      : Overlay1  
  VPN state      : UP  
  Extended vlans   : 5 (Total:1)  
  Join interface(s)  : Eth2/1 (3.3.3.1)  
  Site vlan      : 55 (up)  
  AED-Capable : Yes
  Capability : Unicast-Only
  Is Adjacency Server : Yes
  Adjacency Server(s) : None / None

From the client perspective it tells you who the OTV Adjacency Server is.

OTV-West-Edge-1# show otv 
  VPN name      : Overlay1  
  VPN state      : UP  
  Extended vlans   : 5 (Total:1)  
  Join interface(s)  : Eth2/1 (1.1.1.1)  
  Capability               : Unicast-only
  Is Adjacency Server      : No
  Adj Server Configured    : Yes
  Prim/Sec Adj Svr(s)      : 3.3.3.1 / [None]

Many more articles to come so ....

Please subscribe/comment/+1 if you like my posts as it keeps me motivated to write more and spread the knowledge.

No comments:

Post a Comment