Tuesday, May 22, 2018

Configuring OTV - Site Redundancy - Multiple AEDs

In this blogtorial we are going to expand on my previous blogtorial "Configuring OTV - OTV Configuration and Verification" and configure an extra AED on the West Site to achieve site redundancy.

Here is the topology.



Since the underlay network configurations are the same, please see my previous blogtorial for that part of the configuration.


The relevant configuration for this blogtorial is the OTV-West-Edge-2 shown below.

 hostname OTV-West-Edge-2  
 !  
 feature ospf  
 feature otv  
 !  
 vlan 1,5,55  
 otv site-vlan 55  
 !!  
 interface Overlay1  
  otv join-interface Ethernet2/1  
  otv control-group 233.1.1.1  
  otv data-group 233.1.1.2/32  
  otv extend-vlan 5  
  no shutdown  
 !  
 interface Ethernet2/1  
  ip address 4.4.4.1/30  
  ip igmp version 3  
  no shutdown  
 !  
 interface Ethernet2/2  
  switchport  
  switchport access vlan 5  
  spanning-tree port type edge  
  no shutdown  
 !  
 interface Ethernet2/3  
  switchport  
  switchport access vlan 55  
  spanning-tree port type edge  
  no shutdown  
 !  
 router ospf 1  
  network 0.0.0.0/0 area 0.0.0.0  

Now let's do some verification to see what happened.

 OTV-West-Edge-2# show otv site detail  
 Site Adjacency Information (Site-VLAN: 55) (* - this device)  
 Overlay1 Site-Local Adjacencies (Count: 2)  
  Hostname             System-ID   Up Time  Ordinal  
  -------------------------------- -------------- --------- ----------  
  OTV-West-Edge-1         5000.0001.0006 00:10:37 0  
 * OTV-West-Edge-2         5000.0009.0006 00:09:27 1  

Notice, how there are two IS-IS adjacencies formed. One is intra-site (OTV-West-Edge-1) and the other is inter-site (OTV-East-Edge-1)

 OTV-West-Edge-2# show otv isis adjacency  
 OTV-IS-IS process: default VPN: Overlay1  
 OTV-IS-IS adjacency database:  
 System ID    SNPA      Level State Hold Time Interface  
 5000.0001.0006 5000.0001.0001 1   UP   00:00:25  Overlay1  
 5000.0002.0006 5000.0002.0001 1   UP   00:00:27  Overlay1  

Need to make sure that the VPN state is up. Most of the time this command will tell you what the problem is.

 OTV-West-Edge-2# show otv  
 OTV Overlay Information  
 Overlay interface Overlay1  
  VPN name      : Overlay1  
  VPN state      : UP  
  Extended vlans   : 5 (Total:1)  
  Control group    : 233.1.1.1  
  Data group range(s) : 233.1.1.2/32  
  Join interface(s)  : Eth2/1 (4.4.4.1)  
  Site vlan      : 55 (up)  

Notice that we are learning "mac addresses" through the overlay tunnel.

 OTV-West-Edge-2# show otv route  
 OTV Unicast MAC Routing Table For Overlay1  
 VLAN MAC-Address   Metric Uptime  Owner   Next-hop(s)  
 ---- -------------- ------ -------- --------- -----------  
   5 0050.0000.0500 11   00:00:20 site    Ethernet2/2  
   5 0050.0000.0600 42   00:11:21 overlay  OTV-East-Edge-1  
   5 aabb.cc00.3021 11   00:01:05 site    Ethernet2/2  
   5 aabb.cc00.4020 42   00:11:21 overlay  OTV-East-Edge-1  

The OTV AED has actually changed from OTV-West-Edge-1 to OTV-West-Edge-2. Reason is because higher IS-IS system-id is ODD VLAN primary and lower IS-IS system-id is EVEN VLAN primary. Since OTV-West-Edge-2 system-id is 5000.0009.0006 and OTV-West-Edge-1 system-id is 5000.0001.0006, OTV-West-Edge-2 will be the primary AED for VLAN 5 (odd vlan).

 OTV-West-Edge-2# show otv vlan  
 OTV Extended VLANs and Edge Device State Information (* - AED)  
 VLAN  Auth. Edge Device           Vlan State    Overlay  
 ----  -----------------------------------  ----------    -------  
   5* OTV-West-Edge-2            active      Overlay1  

Now let's start a persistent ping and see what happens when the primary AED has a failure. We are going to mimic the failure by shutting down the join interface ethernet2/1 on OTV-West-Edge-2.

As you can see OTV-West-Edge-2 is active for VLAN 5 and soon as I shut down on the interface ICMP packets begin to drop seq=31 and then it starts backup at seq=41 when the network converges and the OTV-West-Edge-1 is now primary AED for VLAN 5.


As you can see OTV-West-Edge-1 has taken the role of the primary AED as indicated by "active" on the command "show otv vlan".


Many more articles to come so ....

Please subscribe/comment/+1 if you like my posts as it keeps me motivated to write more and spread the knowledge.

No comments:

Post a Comment